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Dear customer, 

every year thousands of customers by our high-quality products  
And they do this for good reason: 

 We offer an excellent price-performance ratio. Reliable quality at a fair price. 

 With a professional experience of over 20 years, we are able to provide you with the best 

possible measuring solutions. 

 Our high demand towards quality. 

 Of course all of our devices bear the CE Mark which is required by the EU. 

 Calibration certificates, seminars and consulting. 

 Even after you have purchased our products you can count to be there for you when you need 

us. 

Through our service you are guaranteed to receive a quick assistance. 
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1 Introduction 

With the help of the CSSoftBasic software, measurement data from the new device series (starting 
from the DS500) can be retrieved, saved, visualized and evaluated. 

2 Installation 

To install the software execute the "Setup.exe" and follow the installation instructions. The software is 
installed automatically. 

3 General 

In this chapter the menu items are described that have the same functionality in all views. 

3.1 Menu File 

3.1.1 New 

3.1.1.1 Read Recorded Data from Device 

With the help of this menu item data can be read into CSSoftBasic from any device. 

After clicking on the menu items the following screen to select the device will be opened. All devices 
which are present in the same network as the computer are displayed in the window. 

 

Illustration1: Automatic device devices 

By double-clicking on the desired device or by selecting it and confirming with OK, a connection to the 
respective device will be established and a list of the available data displayed. 

 Prerequisite:   The device must be connected to the same ethernet network as the computer. 
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Illustration2: Open file 

In the list of all available files, a file can be selected by double-clicking or by selecting it and confirming 
with OK. 

The files may contain data from a large time frame. It is possible to restrict the timeframe through the 
following function. 

 

 Illustration3: File selection  

After selecting the time frame and confirming with "OK" the following window will open. 

 

 Illustration4: Entering a file name 

The default name for the "Filename" is automatically generated from the comment that was input into 
the device. For the "file name" only contain small letters and numbers without spaces or special 
characters may be used. Both the "Filename" and the "Comment" may be changed by the operator. 
As the default comment, the comment that was entered into the device for the measurement will be 
used. 

After a confirmation with "OK" the data transfer will start. An individual file for every day will be stored 
internally in the device. These files are successively loaded and decoded. 
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CAUTION: For large amounts of data, data import may take some time to complete. 

In order to load multiple files simultaneously, in the window Illustration2: Open file, you can mark 
several files. For this, use the standard Windows keys "Ctrl" or "Shift".  
When selecting multiple files, the time frame as shown in  Illustration3: File selection  can not be 
restricted. 

 

3.1.1.2 Read Device File 

If data has been transferred to a USB flash drive, it can be read via this menu item. The folders stored 
on the USB drive folders can be stored on any medium. The files in the "export" folder must always be 
stored in a single folder. The file names may not be changed. 

 

After clicking on the menu item the following screen to select the data (RECORDS.LOG) will be 
opened: 

 

 Illustration5: open Records.log 

Select the desired folder containing the RECORDS.LOG file and confirm by clicking on the button 
"open". 

Just as described under 3.1.1.1 Read Recorded Data from Device, individual files and their time 
frames can now be selected. 

3.1.2 Open  

A file can be opened using this menu item. For this, the following dialog is displayed: 
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 Illustration6: Open file 

By double-clicking or by selecting and confirming the respective file will be opened. 

Incorrect files can be clearly identified as such, if they do not contain any entries except for the name 
(see  Illustration6: Open file entry "measurement_3_23"). 

 

3.1.3 Merge 

With this menu item different files can be merged.  

 

 Illustration7: Merging files 

Select the files you want to merge. 

After confirming with "OK" the following window will open. 
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 Illustration8: Enter a filename for the merged file. 

The merged files will be stored in a new file. 
Here you can assign any name for the new file. The "file name" may only contain small letters and 
numbers without spaces or special characters. Both the "file name" and the "comment" may be 
changed by the operator. 

After confirming with "OK" the files will be merged. 

 

 Illustration9: Merging status 

During the merge process, you will receive detailed information in the status window. 

3.1.4 Export 

This function is intended for moving a file to a different computer or to perform a data backup. 

 

 Illustration10: Exporting 

The desired file can be selected in the dialogue. The target path must be specified additionally. 
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3.1.5 Import 

In order to be able to use in exported file it must first be imported. 

 

Illustration11: Importing 

For this, the exported file must be selected. 

3.1.6 Delete 

Old data can be deleted through this menu item. 
The file can be selected through the following dialog. 

 

 Illustration12: File deletion  

CAUTION: If the data was not secured previously with an export, the data will be irrevocably deleted!!! 

3.1.7 Exit 

Exiting CSSoftBasic 
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3.2 View menu 

 With this menu item a switching to the different views can be performed. 

3.3 Info menu 

3.3.1 Help 

 Call-up of the help file (PDF file). 

3.3.2 Language 

 Opens the dialogue for the language selection: 

 

 Illustration13: Language selection 

 In the ComboBox, all selectable languages will be displayed. 

 The application will automatically be restarted after a different language has been selected. 

. 

3.3.3 License 

 The current licensing information can be accessed via "Info->License". 

 Further information regarding the licensing can be found under 7 Licensing. 

3.3.4 About 

 The current version information will be displayed. 
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4 Overview 

 After the startup the "overview" view will always be displayed. 

 If you are in a different view, you can always switch back to the overview through the menu 
item "View -> Overview". 

 In this view the current measurement values of a device can be displayed. 

 The real-time data recording can also be started in this view. 

Menu item Toolbar Action 

Edit -> Connect 

 

Establish a connection to a 
device. 

Edit -> Disconnect 
 

Separates the connection. 

Edit -> Real-time Data Recording 
 

Real-time data recording 

 Table 1: Edit overview  

 Using the context menu, the following actions can be performed: 

o Establish Connection: Establishes a connection to the device. 
o Separate the connection: Separates the connection. 
o Real-time data recording Starts the real-time data recording 

4.1 Display current measurement values 

 In order to be able to display the current measurement values of a device, a connection to that 
device must be established. 

 The connection to a device can be established via the corresponding menu item, toolbar or 
the context menu (see 4 Overview). 

 For the selection of the appropriate device the following dialog will be displayed: 
 

 

 Illustration14: Establish connection 

By double-clicking or respectively selecting and confirming with "OK", all the measurement 
values of the selected device will be displayed. 
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Illustration15: Current measurement values  

4.2 Record current measurement values  

 In order to be able to record the current measurement values to a file, a connection to that 
device must be established. 
In section 4.1 Display current measurement values this item is described step by step. 

 The data recording can be started with the appropriate menu item, the toolbar or the context 
menu. 

 After starting the data recording a file name must be specified. The filename must be unique 
and may only consist of small letters, numbers and underlines. If other characters are entered 
they will be ignored. 
A comment can also be input. 
 

 

Illustration16: Real-time data recording naming 

 The real-time data is displayed in the following dialog. The operation is set up analogously to 
the data view. Respective details can be found under 5.1 Diagram View. 
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Illustration17: Real-time data recording 

 Closing the "Real-time data recording" dialogue will also cancel the data recording. All 
available channels are always logged independent from the number of currently displayed 
channels. 
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5 Data 

 With the menu item "View -> Data" a switch to the data view can be performed. 

 In the Diagram Explorer, the devices are displayed in a tree structure (range, device, 
measured value). The range name is automatically assigned and always corresponds to the 
host name of the device. 

 With the Diagram Explorer data rows can be added or deleted by double-clicking on the 
appropriate measurement value. 

 Data rows can also be added/deleted through the context menu. 

 

 Illustration18: Diagram Explorer 

 The line style can be changed via the context menu: 

 

 Illustration19: Line Style 

 In addition, the setting of the Y-axis is changed via the context menu. An Y-axis is added for 
each measured variable. 

 

 Illustration20: Y-axis scaling 
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 Depending on the selection of the TabControl in the Diagram Explorer, a different data field is 
loaded. The data is read optimized from the database (grouping of data - the maximum 
number of possible data points (screen width)). With the button "<<" or ">>" the same time 
span before or after is read from the database. 

 The Diagram Explorer can be docked to the left or right, or used as a floating window 
(Windows standard). 

5.1 Diagram View 

 In the diagram view, the selected range is presented graphically: 

 

 Illustration21: Diagram View 

 Zoom: 
Depending on the selection in the Diagram Explorer the X-axis (X-axis zoom) and/or Y-axis 
(Y-axis zoom) can be enlarged or reduced by using the scroll wheel. The selection can also be 
made via the context menu. 
 
By pressing the Shift key and selecting the desired range, the selected range is enlarged. 
 
By pressing the shift key and clicking an enlargement by one increment will be made. 
 
Pressing the ALT key and clicking will effect a reduction. 

 Measuring points: 
If the data does not have to be grouped for displaying, the raw data will be shown. The 
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measured value will be output in the tooltip. 

 

 Illustration22: Raw data diagram 

 Scrolling: 
Depending on the selection in the Diagram Explorer a scrolling is carried out along the x-axis 
(X-axis scrolling) and/or the Y-axis. The selection can also be made via the context menu. 
Hold down the left mouse button for scrolling. 

 Reset Y-scaling: 
Using the context menu "Zoom -> Reset Y-Axis scaling" all Y-axes are reset to auto scaling. 

 Data reloading: 
After zooming, you can use the context menu " Apply current timespan" to load the maximum 
amount of data for the selected range. 

 Moving average: 
Using the context menu or the menu "Edit -> Moving average -> Show Moving Average" the 
moving average can be displayed/suppressed for all data rows. 
Using the menu "Edit -> Moving average -> Properties" the moving average can be 
configured. 

 

 Illustration23: Moving average 

 Export: 
Through the context menu "Export ..." the current diagram can be exported in different 
document formats (PDF, HTML, MHT, Rich Text, Excel, CSV, text, graphic) or printed through 
the context menu "File -> Print ...". 

 Settings: 
The settings can be saved, loaded or deleted through the menu "Settings". 
The settings file contains the currently displayed data rows, the settings (color, width, scale ...) 
and the moving average. 



 CSSoftBasic  

 

2011-10-24 Manual Rev. D Page 20 of 27 

 

Under "Settings->Load" only those settings files will be available which were saved with the 
identical device configuration. 

5.2 Statistics 

 The loaded files are statistically evaluated and can be displayed through the "Statistics" tab. 
  

 

 Illustration24: Statistical analysis 

 The statistical analysis can be printed with or without a graphic through the context menu or 
the menu "File -> Print". 
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5.3 Tabular View 

 The loaded measurement values are displayed in a tabular form and can be displayed through 
the "Tabular view" tab. 

  

Illustration25: Tabular view 

 If a range is marked in the table, the current data range can be loaded additionally through the 
context "Apply current timespan". 

 The table view can be output with the context menu "Export ..." or "File -> Print". 

5.4 Raw Data 

 In the tab "Tabular view raw data" of the raw data for the selected measurement values are 
output. If the number of data exceeds the width of the chart, the grouped data is output, 
otherwise the raw data. 
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 Illustration26: Raw Data 

 The raw data can be output with the context menu "Export ..." or "File -> Print". 

 With the context menu or the table heading the raw data can be output: 
 
a) sorted 
 

 

 Illustration27: Chronological sorting ascending 

b) filtered 

 

Illustration28: Filter - channel "A4" 
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c) grouped 
 

 

 Illustration29: Grouping "channel" 

. 
 

 

 

6 Analysis 

 With the menu item "View -> Analysis“ the consumption analysis can be started. 

  

 Illustration30: Consumption Analysis 

 In the left area all the devices with consumption sensors are listed which are not considered 
during the consumption analysis. 
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 In the right area all the devices with consumption sensors are listed which are evaluated 
during the consumption analysis. 

 By double-clicking complete ranges or just individual units or measuring channels can be 
moved from left to right or from right to left. 
Likewise be selected range/device/measuring channel can be marked and moved with the 
"left arrow" or "right arrow" buttons. 

 The order of the ranges, devices and measuring channels can also be defined. For this, use 
the "up arrow" or "down arrow" buttons. 

 Through the menu item "Extras->Configuration" a price per unit as well as the rate 
selection/rate definition can be defined for every consumption channel. 

 

 Illustration31: Consumption Analysis configuration 

 Please observe - that devices which are located in a main or sum branch may not be 
included if a correct sum-calculation is to be performed. 

 Additionally, in order to perform a correct sum calculation only consumption variables 
with the same unit may be included. 

 The configuration can be saved with the menu "File->Save" or with the respective icon. At a 
later point in time a saved configuration can be loaded through "File-> Open". The file 
extension "*.csua" is used for the configuration files of the consumption analysis. A new 
configuration is created with the menu "File->New". 

 Depending on the selection of the tab control, a weekly, monthly or annual report will be 
created. 
 

 

 Illustration32: Consumption Analysis 

 Through the menu "File" the preview can be output in different document formats (PDF, 
HTML, MHT, Rich Text, Excel, CSV, text, graphic) or printed. 
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7 Licensing 

 After the installation you will automatically have a test version which is valid for 10 days. At the 
start of CSSoftBasic the remaining evaluation time will be displayed in the following dialog. 

 

 Illustration33: Info test version 
 

 With "?" you can select a different language. 

 If you downloaded the software from our homepage you can purchase a serial number in our 
online shop with the button "Purchase a serial number". 

 If you have a serial number, you can activate the software. 

 There are four ways to activate the software: 

 

Illustration34: Activation options 

 Please use in the "Online Activation" option if you're computer has an Internet connection. If 
your computer does not have Internet access, you can use "E-mail Activation" to activate any 
computer via e-mail. 
With the e-mail the activation code will be sent to you within 15 minutes.  

 Please use the registration by fax or telephone only if you do not have Internet access. 
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 In the next step (independent from your activation option) please enter your activation data. 

 

 Illustration35: Activation data 

 With the "Online Activation" the registration is automatically completed, otherwise you must 
enter the activation key that has been sent to you at a later point in time through "Info-
>Licence button "Activation Key". 

If the software was activated online, there is the possibility of using the button "Transfer License" to 
transfer the software from computer A to computer B. 
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8 Support and Service 

If you have questions about our products, require technical support for the installation or use of our 
software or if you would like to give us a suggestion for improvements, CS Instruments GmbH offers 
you the following support options: 

Please contact us preferably via the following Internet site: 

http://support.cs-instruments.com 

 

On this website CS Instruments GmbH has set up a forum for its customers. Here you can benefit 
from the fact that perhaps another customers have asked the same question and we have already 
posted the answer under the heading "Frequently Asked Questions" (FAQ). Beyond that, you also 
have the opportunity to directly address a question to us here. 

If you currently do not require any support but are still interested in our products and would like to 
follow the development on this website, we will provide the interested reader with the opportunity to 
receive information about new posts in the forum via RSS feeds. 

The link to our RSS feed: 
http://support.cs-instruments.com/posts.rss 

 

Of course, you can also reach us by e-mail or phone. For this, please use the following e-mail address 
or the following phone number. 

support@cs-instrumnts.com 

 (Zen desk - Helpdesk) 

 

+49 461 7002025 

Phone support and Teamviewer access 
(15 minutes = 30 Euro, minimum 45min) 

 

Please don't hesitate to send us a message. We will answer all inquiries within 24-48 hours. 

 

http://support.cs-instruments.com/
http://support.cs-instruments.com/posts.rss
mailto:support@cs-instrumnts.com
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