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Dear customer, 

Every year thousands of customers buy our high-quality products  
And they do this for good reason: 

 We offer an excellent price-performance ratio. Reliable quality at a fair price. 

 With a professional experience of over 20 years, we are able to provide you with the best 

possible measuring solutions. 

 Our high demand towards quality. 

 Of course all of our devices bear the CE Mark which is required by the EU. 

 Calibration certificates, seminars and consulting. 

 Even after you have purchased our products you can count to be there for you when you need 

us. 

Through our service you are guaranteed to receive a quick assistance. 
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1 Introduction 

With the help of the CS Soft Basic software, measurement data from the new device series (starting 
from the DS500) can be retrieved, saved, visualized and evaluated. 

2 Installation 

To install the software execute the "Setup.exe" and follow the installation instructions. The software is 
installed automatically. 

3 General 

In this chapter the menu items are described that have the same functionality in all views. 

3.1 Menu File 

3.1.1 New 

3.1.1.1 Read Recorded Data from Device 

With the help of this menu item data can be read into CS Soft Basic from any device. 

After clicking on the menu items the following screen to select the device will be opened. All devices 
which are present in the same network as the computer are displayed in the window. 

 

Illustration 1: Automatic device devices 

 

By double-clicking on the desired device or by selecting it and confirming with OK, a connection to the 
respective device will be established and a list of the available data displayed. 

 Prerequisite:   The device must be connected to the same ethernet network as the computer. 
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Illustration 2: Open file 

In the list of all available files, a file can be selected by double-clicking or by selecting it and confirming 
with OK. 

The files may contain data from a large time frame. It is possible to restrict the timeframe through the 
following function. 

 

Illustration 3: File selection 

After selecting the time frame and confirming with "OK" the following window will open. 

 

Illustration 4: Entering a file name 

The default name for the "Filename" is automatically generated from the comment that was input into 
the device. For the "file name" only contain small letters and numbers without spaces or special 
characters may be used. Both the "Filename" and the "Comment" may be changed by the operator. 
As the default comment, the comment that was entered into the device for the measurement will be 
used. 

After a confirmation with "OK" the data transfer will start. An individual file for every day will be stored 
internally in the device. These files are successively loaded and decoded. 

CAUTION: For large amounts of data, data import may take some time to complete. 
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In order to load multiple files simultaneously, in the window Illustration 2, you can mark several files. 
For this, use the standard Windows keys "Ctrl" or "Shift".  
When selecting multiple files, the time frame as shown in Illustration 3 can not be restricted. 

 

3.1.1.2 Read Device File 

If data has been transferred to a USB flash drive, it can be read via this menu item. The folders stored 
on the USB drive folders can be stored on any medium. The files in the "export" folder must always be 
stored in a single folder. The file names may not be changed. 

 

After clicking on the menu item the following screen to select the data (RECORDS.LOG) will be 
opened: 

 

Illustration 5: open Records.log 

Select the desired folder containing the RECORDS.LOG file and confirm by clicking on the button 
"open". 

Just as described under 3.1.1.1 Read Recorded Data from Device, individual files and their time 
frames can now be selected. 

  



 CS Soft Basic  

 

2014-10-01 Manual Rev. G Page 10 of 55 

 

3.1.2 Open  

A file can be opened using this menu item. For this, the following dialog is displayed: 

 

Illustration 6: Open file 

By double-clicking or by selecting and confirming the respective file will be opened. 

Incorrect files can be clearly identified as such, if they do not contain any entries except for the name. 

 

3.1.3 Merge 

With this menu item different files can be merged.  

 

Illustration 7: Merging files 

Select the files you want to merge. 

After confirming with "OK" the following window will open. 
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Illustration 8: Enter a filename for the merged file. 

The merged files will be stored in a new file. 
Here you can assign any name for the new file. The "file name" may only contain small letters and 
numbers without spaces or special characters. Both the "file name" and the "comment" may be 
changed by the operator. 

After confirming with "OK" the files will be merged. 

 

Illustration 9: Merging status 

During the merge process, you will receive detailed information in the status window. 

3.1.4 Export 

3.1.4.1 Dump (CS Soft Basic): 

This function is intended for moving a file to a different computer or to perform a data backup. 

 

Illustration 10: Exporting 

The desired file can be selected in the dialogue. The target path must be specified additionally. 
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3.1.4.2 Data as *.csv 

This function serves for viewing the raw data in spread sheet systems (e. g. Excel). 
Optionally the format can be selected in English or German notation. In order to export the 
data please mark the array/s and click to “Export“. 
 

 

Illustration 11: Export of raw data as CSV file 

Under 8 you will find a short instruction how to open the CSV file in Excel.   

3.1.5 Import 

In order to be able to use in exported file (Dump from CS Soft Basic or DS300-Data) it must first be 
imported. 

3.1.5.1 Dump (CS Soft Basic Export) 

Files which have been generated via the menu point File -> Export -> Dump (CS Soft Basic) (see 
3.1.4.1), can be imported via this function. 

 

Illustration 12: Importing 

The file to be imported is selected via the button “…“  and the import will be started via the button 
“OK“.  

3.1.5.2 DS300 data (csv file) 

CSV files which have been issued by means of the software CSM-S can be imported via this menu 
point. So there is the possibility to analyse data which have been recorded by DS300 by means of the 
CS Soft Basic. 
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Illustration 13: Import of a CSV file 

Upon selection of the DS300 CSV file to be imported you will find in the bottom some important 
information on the file. 

After starting the import procedure a unique file name has to be allocated (Default: ds300): 

 

Illustration 14: Creation of the database out of a CSV file 

The designation of the single channels can be adapted during the import: 

 

Illustration 15: Adaptation of the data designation (Import of CSV file) 
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3.1.6 Delete 

Old data can be deleted through this menu item. 
The file can be selected through the following dialog. 

 

Illustration 16: File deletion 

CAUTION: If the data was not secured previously with an export, the data will be irrevocably deleted!!! 

3.1.7 Exit 

Exiting CS Soft Basic. 
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3.2 View menu 

 With this menu item a switching to the different views can be performed. 

3.3 Info menu 

3.3.1 Help 

 Call-up of the help file (PDF file). 

3.3.2 Language 

 Opens the dialogue for the language selection: 

 

Illustration 17: Language selection 

 In the ComboBox, all selectable languages will be displayed. 

 The application will automatically be restarted after a different language has been selected. 

. 

3.3.3 License 

 The current licensing information can be accessed via "Info->License". 

 Further information regarding the licensing can be found under 9 Licensing. 

3.3.4 About 

 The current version information will be displayed. 
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4 Overview 

 After the startup the "overview" view will always be displayed. 

 If you are in a different view, you can always switch back to the overview through the menu 
item "View -> Overview". 

 In this view the current measurement values of a device can be displayed. 

 The real-time data recording can also be started in this view. 

Menu item Toolbar Action 

Edit -> Connect  Establish a connection to a 
device. 

Edit -> Disconnect  Separates the connection. 

Edit -> Real-time Data Recording  Real-time data recording 

 Table 1: Edit overview  

 Using the context menu, the following actions can be performed: 

o Establish Connection: Establishes a connection to the device. 
o Separate the connection: Separates the connection. 
o Real-time data recording Starts the real-time data recording 

4.1 Display current measurement values 

 In order to be able to display the current measurement values of a device, a connection to that 
device must be established. 

 The connection to a device can be established via the corresponding menu item, toolbar or 
the context menu (see 4 Overview). 

 For the selection of the appropriate device the following dialog will be displayed: 
 

 

Illustration 18: Establish connection 

By double-clicking or respectively selecting and confirming with "OK", all the measurement 
values of the selected device will be displayed. 
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Illustration 19: Current measurement values 

4.2 Record current measurement values  

 In order to be able to record the current measurement values to a file, a connection to that 
device must be established. 
In section 4.1 Display current measurement values this item is described step by step. 

 The data recording can be started with the appropriate menu item, the toolbar or the context 
menu. 

 After starting the data recording a file name must be specified. The filename must be unique 
and may only consist of small letters, numbers and underlines. If other characters are entered 
they will be ignored. 
A comment can also be input. 
 

 

Illustration 20: Real-time data recording naming 

 The real-time data is displayed in the following dialog. The operation is set up analogously to 
the data view. Respective details can be found under 5.1 Diagram View. 
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Illustration 21: Real-time data recording 

 Closing the "Real-time data recording" dialogue will also cancel the data recording. All 
available channels are always logged independent from the number of currently displayed 
channels. 
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5 Data 

 With the menu item "View -> Data" a switch to the data view can be performed. 

 In the Diagram Explorer, the devices are displayed in a tree structure (range, device, 
measured value). The range name is automatically assigned and always corresponds to the 
host name of the device. 

 With the Diagram Explorer data rows can be added or deleted by double-clicking on the 
appropriate measurement value. 

 Data rows can also be added/deleted through the context menu. 

 

Illustration 22: Diagram Explorer 

 The line style can be changed via the context menu. 
If “Show Average” is selected then the data will be shown as average values. Otherwise the 
data will be shown as extremums (minimum and maximum values). 
If the data row is displayed as stacked area, the number under the checkbox will be the 
smoothing factor. 
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Illustration 23: Line Style 

 

 In addition, the setting of the Y-axis is changed via the context menu. An Y-axis is added for 
each measured variable. 

 

Illustration 24: Y-axis scaling 

 Depending on the selection of the TabControl in the Diagram Explorer, a different data field is 
loaded. The data is read optimized from the database (grouping of data - the maximum 
number of possible data points (screen width)). With the button "<<" or ">>" the same time 
span before or after is read from the database. 

 Using “Default” the range is set to the maximum range. 

 The Diagram Explorer can be docked to the left or right, or used as a floating window 
(Windows standard). 
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5.1 Diagram View 

 In the diagram view, the selected range is presented graphically: 

 

Illustration 25: Diagram View 

 View:  
The measured values can be displayed either as average or as minimum / maximum values. 

 Zoom: 
Depending on the selection in the Diagram Explorer the X-axis (X-axis zoom) and/or Y-axis 
(Y-axis zoom) can be enlarged or reduced by using the scroll wheel. The selection can also be 
made via the context menu. 
 
By pressing the Shift key and selecting the desired range, the selected range is enlarged. 
 
By pressing the shift key and clicking an enlargement by one increment will be made. 
 
Pressing the ALT key and clicking will effect a reduction. 
 
Pressing the STRG key and +-key will lead to an enlargement by one increment. 
Pressing the STRG key and – key will lead to a reduction by one increment.  

 Measuring points: 
If the data does not have to be grouped for displaying, the raw data will be shown. The 
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measured value will be output in the tooltip. 

 

Illustration 26: Raw data diagram 

 Stacked areas: 
If in the line style “stacked areas“ is selected the array is indicated as stacked area. 

 

Illustration 27: Stacked areas 

 Scrolling: 
Depending on the selection in the Diagram Explorer a scrolling is carried out along the x-axis 
(X-axis scrolling) and/or the Y-axis. The selection can also be made via the context menu. 
Hold down the left mouse button for scrolling. 

 Reset Y-scaling: 
Using the context menu "Zoom -> Reset Y-Axis scaling" all Y-axes are reset to auto scaling. 

 Data reloading: 
After zooming, you can use the context menu " Apply current timespan" to load the maximum 
amount of data for the selected range. 

 Moving average: 
Using the context menu or the menu "Edit -> Moving average -> Show Moving Average" the 
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moving average can be displayed/suppressed for all data rows. 
Using the menu "Edit -> Moving average -> Properties" the moving average can be 
configured. 

 

Illustration 28: Moving average 

 Export: 
Through the context menu "Export ..." the current diagram can be exported in different 
document formats (PDF, HTML, MHT, Rich Text, Excel, CSV, text, graphic) or printed through 
the context menu "File -> Print ...". 
 

 The chart diagram can be exported in the following formats: 
a) Hourly: One chart diagram per hour. 
b) Daily: One chart diagram per day. 
c) Weekly: One chart diagram per week. 
d) Selected timespan: print of current chart diagram. 

 

 Settings: 
The settings can be saved, loaded or deleted through the menu "Settings". 
The settings file contains the currently displayed data rows, the settings (color, width, scale ...) 
and the moving average. 
Under "Settings->Load" only those settings files will be available which were saved with the 
identical device configuration. 

5.2 Statistics 

 The loaded files are statistically evaluated and can be displayed through the "Statistics" tab. 
  

 

Illustration 29: Statistical analysis 

 The statistical analysis can be printed with or without a graphic through the context menu or 
the menu "File -> Print". 



 CS Soft Basic  

 

2014-10-01 Manual Rev. G Page 24 of 55 

 

5.3 Tabular View 

 The loaded measurement values are displayed in a tabular form and can be displayed through 
the "Tabular view" tab. 

  

Illustration 30: Tabular view 

 If a range is marked in the table, the current data range can be loaded additionally through the 
context "Apply current timespan". 

 The table view can be output with the context menu "Export ..." or "File -> Print". 
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5.4 Raw Data 

 In the tab "Tabular view raw data" of the raw data for the selected measurement values are 
output. If the number of data exceeds the width of the chart, the grouped data is output, 
otherwise the raw data. 
 

 

Illustration 31: Raw Data 

 The raw data can be output with the context menu "Export ..." or "File -> Print". 

 With the context menu or the table heading the raw data can be output: 
 
a) sorted 
 

 

Illustration 32: Chronological sorting ascending 
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b) filtered 

 

Illustration 33: Filter - channel "A4" 

c) grouped 
 

 

Illustration 34: Grouping "channel" 

5.5 Extras 

5.5.1 Settings 

The settings of the actual diagram view can be saved via the menu point “Extras -> Settings -> Save“. 

The load of stored settings is effected via the menu point ”Extras -> Settings -> Load“. 

Via the menu point “Extras -> Settings -> Delete“, saved settings are deleted. 

This function is very helpful in order to avoid a permanent fade-in and fade-out of any arrays or doing 
a permanent adaptation of the layout. 
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6 Analysis 

 With the menu item "View -> Analysis“ the consumption analysis can be started. 

   

Illustration 35: Consumption Analysis 

 In the left area all the devices with consumption sensors are listed which are not considered 
during the consumption analysis. 

 In the right area all the devices with consumption sensors are listed which are evaluated 
during the consumption analysis. 

 By double-clicking complete ranges or just individual units or measuring channels can be 
moved from left to right or from right to left. 
Likewise be selected range/device/measuring channel can be marked and moved with the 
"left arrow" or "right arrow" buttons. 

 The order of the ranges, devices and measuring channels can also be defined. For this, use 
the "up arrow" or "down arrow" buttons. 

 Through the menu item "Extras->Config->Price" a price per unit as well as the rate 
selection/rate definition can be defined for every consumption channel. 

 

Illustration 36: Consumption Analysis configuration 

 Up to 5 shifts can be defined via the menu point „Extras->Config->shift work”. The shifts have 
to be carried out within one day and are not allowed to overlap, otherwise there will be an 
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error message when confirming the input with the „OK“ button. 
The starting point of the first shift is allocated to the current day or the following day via the list 
field „Allocation of the shift start 1 to“. 
 
Example: 

Example 1 Example 2 

Start of shift:         22:00 h 
End of shift:          6:00 h 
Allocation:            next day 

Start of shift:        22:00 h 
End of shift:         6:00 h 
Allocation:           actual day 

If the first shift e. g. starts on Sunday at 
22:00 h and ends on Monday at 6:00 h the 
shift in this example will be allocated to 
Monday. 

If the first shift e. g. starts on Sunday at 
22:00 h and ends on Monday at 6:00 h the 
shift in this example will be allocated to 
Sunday. 

 

 

Illustration 37: Configuration shift work 

 Please observe - that devices which are located in a main or sum branch may not be 
included if a correct sum-calculation is to be performed. 

 Additionally, in order to perform a correct sum calculation only consumption variables 
with the same unit may be included. 

 The configuration can be saved with the menu "File->Save" or with the respective icon. At a 
later point in time a saved configuration can be loaded through "File-> Open". The file 
extension "*.csua" is used for the configuration files of the consumption analysis. A new 
configuration is created with the menu "File->New". 
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 Depending on the selection of the tab control, a weekly, monthly or annual report will be 
created. 

 When selecting the tab control „custom“ a consumption analysis of the pre-selected type will 
be generated for the selected period of time. 

 The generation of the shift report can be activated/deactivated via the check box „shift report“. 
 

 

Illustration 38: Consumption Analysis 

 Through the menu "File" the preview can be output in different document formats (PDF, 
HTML, MHT, Rich Text, Excel, CSV, text, graphic) or printed. 
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7 Option Compressor Analysis 

The compressor analysis is only available if a license for the CAA module is bought. 

 Via the menu point “View -> Analysis -> CS Soft Energy Analyzer“ the compressor analysis is 
started. 
 

 

Illustration 39: Compressor analysis 

 All configured compressors are listed in the table. 

 In the area „“Total flow rate“ it is fixed how the calculation of the flow is done. 
o Sum of selected compressors:  

Summation of the calculated compressor air delivery 
o Flow sensor:  

Physical measured value of the used sensors in the total pipeline. 

 For calculation of the leakage costs the check box “Analysis active” has to be activated. The 
leakage is graphically adjustable via the button “Set“ (see 7.4). 

 The evaluation period of the compressor analysis is fixed in the area “timespan“. 
By means of the button “Reset“ the evaluation period is fixed to the maximum period of time 
of the actual database. 

 In the normal case solely the report ”energy and cost evaluation” is generated. If additional 
reports are desired they can be activated via the corresponding check boxes in the area 
“additional reports“ (details to the reports please see 7.5). 

 By means of a right-click onto the header of the table the compressors can be assorted and 
filtered. 
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Illustration 40: Context menu ‘group by this column‘ 

 One further possibility to filter and assort is to click onto the filter (marked red) in the table 
header. 

 

Illustration 41: Filter 

 The following menu is indicated: 

  

Illustration 42: Example of a user-defined filter 

 The order of the compressors can also be defined.  For this purpose please use the button 
“arrow up“ and the button ”arrow down“. 

 

Illustration 43: Compressors assorted according to type 

 Please observe that this order of assortation is also taken over for the graphic indication in 
the diagram view. 
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7.1 General settings 

 The general settings of the compressor analysis can be done in the menu point ”Extras -> 
Config -> Common“.  

 The units which have to be used for the values to be calculated can be fixed under “Unit“. 

 The number of hours per year with which the CS Soft Energy Analyzer calculates the 
statistics for one year can be entered. 

 

Illustration 44: Definition of general parameters for the compressor analysis 

 The tariff costs are fixed under “Price“. 

 

Illustration 45: Price definition 
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7.2 Compressor configuration 

The different compressors are defined under “Extras -> Config -> Compressor configuration“. Via the 
flag (load/unload compressor, piston compressor and frequency controlled compressor) the different 
compressor types can be selected. 

All already defined compressors of the corresponding compressor type are listed in the table. 

The compressor parameters are indicated/set in the lower area. 

 

Illustration 46: Configuration of the compressor 

 Adding a compressor: Click to . 
You can either choose to edit the compressor in the above screen or to access to a pool of 
already defined compressors in the compressor database (see Chapter 7.3). 

 The compressor is edited with the button “Accept“ and the necessary measured values are 
calculated. Tthe added compressor is indicated in the diagram explorer. The measured values 
of the compressor can be indicated as usual in the diagram view (see 5.1). 

 Editing of a compressor: Click to . 
By means of “Accept“ the alterations will be saved. 

 Deletion of a compressor: Click to . 

 Important: If the flow or the consumption are set to “none“ these values are calculated 
by means of the ”air delivery at load”. 
“Air delivery at load” is the theoretical value specified in the configuration. 

 The threshold values can be stored graphically under „“Limit value“ (see 7.4). 

 If the threshold values are not to be entered in amps but rather in kW, then the radio button on 
the right side can be used to either select “Insert A" or “Insert kW”. 
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7.3 The compressor database 

The compressor database contains all compressors defined on the computer. There is an own 
database for each compressor type. 
 

 

Illustration 47: Survey compressor database 

 Basic functions: 
Add a new compressor:     
Edit an existing compressor:   
Delete an existing compressor:   
Copy an existing compressor:   
 

 Editing of compressors: 
As an alternative the compressors can also be edited via a menu. 
 

 

Illustration 48: Edit compressor 

 The compressor databases are stored as XML files on the computer. So it is possible to edit the 
database manually via a text/XML editor. The XML files can be exchanged between different 
computers without any problems.  

 The compressor database can be exported resp. imported via the corresponding manu points (File 
-> Export, File -> Import).  

 

Illustration 49: Import / Export XML files 
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7.4 Graphic settings of threshold values 

The leakage and the load, unload and stop range of compressors can be also fixed graphically.  

 General functions: 
Like in case of the diagram view (see 5.1) the data are read-out optimized from the database. 
It is also possible to boost or to scale down the view. 

 At the left edge the unit of the channel is indicated. Via a red bar the treshold values resp. the 
leakage can be set. 

 As an alternative the threshold values can also be set in the corresponding fields which are in 
the right upper edge. 

 The timespan can be selected like in case of the Tabcontrol in the diagram view. 
If the selected timespan is out of the period of measurement the corresponding field is marked 
in red color. 
If “Default“ is selected the timespan is reset to the maximum period of measurement which is 
indicated under “Info. 
 

 

Illustration 50: Leakage 
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Illustration 51: Threshold values load/unload compressor 
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7.5 Compressor analysis: Reports 

 Cover sheet 

 

Illustration 52: Example for a report (cover sheet) 
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 Compressor parameters 

 

Illustration 53: Example for a report (compressor parameters) 
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 Energy and cost analysis 

 

Illustration 54: Example for a report (Energy and cost analysis) 

 

 

 

 Cumulated energy and cost analysis 

 

Illustration 55: Example for a report (energy and cost analysis cumulated to 8700 hours) 
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 Load analysis 
 

 
  



 CS Soft Basic  

 

2014-10-01 Manual Rev. G Page 41 of 55 

 

 

Illustration 56: Example for a report (load analysis) 
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Illustration 57: Daily Measurement Analysis 
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7.6 Evaluation using an example 

In this sample file, the current consumption of 2 compressors has been measured with the DS 500 

mobile and 2 current probes. 

 

a) Open the file and switch to the chart View. 

 

b) Via the menu point “View -> Analysis -> Compressed Air” you will reach the compressor analysis. 

 

 

Illustration 58 : select compressor analysis 

c) Select in the “compressor analysis” window the menu point “extras -> Configuration -> Common”. 
 

 

Illustration 59 : Select common configuration for compressor analysis 

 

 

 

 

d) Here, the units, the currency and the number of hours per year, with which the CS Soft Energy 

Analyzer calculates the statistics for one year, can be entered. 

Under the “Price” tab, the price per kWh, with which the software should calculate, can be entered. 

 

 

Illustration 60 : Common configuration for compressor analysis 

e) In the compressor analysis window, select “Extras -> Configuration -> Compressor”. 
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Illustration 61 : Select configuration compressor 

 

 

 

 

f) In the “Configuration compressor” screen, 3 different types of compressors (full/no load 

compressor, piston compressor or speed-controlled compressor) can be configured. 

Already configured compressors can be stored in a compressor database. 

In this example, 2 new compressors of the type “full/no load compressor” will be created. 

With the button  you will reach the compressor database. 

 

g) Perform the adding with the button  or via the menu “Edit -> Add”. 

 

 

Illustration 62 : Add compressor to database 

h) In this window, all the relevant data of the compressor can be entered according to the 

manufacturer's specifications. Provided that at this point still no statement can be made regarding 

at which current consumption the compressor will be operating under load and at what power 

consumption the compressor will be idling, or respectively switched to the stop mode, this can also 

be corrected at a later point in time. With the “Apply” button, the compressor will be added to the 

database. 

 

In this example, a compressor with a power of 7.5 kW (usually the mechanical shaft power is 

specified by the manufacturer) was created. 

The threshold limit settings were made as follows: 

If the current consumption is > 10 amps this time will be calculated by the software as under load. 

Hereby, the power calculation is performed with a cos phi factor of 0.86. 

If the current consumption is < 10 amps this time will be calculated by the software as idle. 

Hereby, the calculation is performed with a cos phi factor of 0.5. 

If the current consumption falls below 0.5 amps, the compressor will be in standstill and if 

anything, only the controller etc. will be running. This time will be calculated by the software as a 

stop time. 

If the threshold values are not to be entered in amps but rather in kW, then the radio button on the 

right side can be used to either select “Insert A" or “Insert kW”. 



 CS Soft Basic  

 

2014-10-01 Manual Rev. G Page 45 of 55 

 

 

Illustration 63 : Edit compressor 

 
i) After the compressor was taken over from the compressor database, further detail settings can be 

performed under “Configuration compressor”. For this, enable the entry fields with the  "Edit" 

button. 

 

Under “Assigned values” the measurement channel of the DS500 with which the compressor was 

measured must be assigned to the compressor. In this example, the compressor GA 7 was 

measured on the DS500 A2a measuring channel with a current probe. 

 

If the actual delivered quantity of air was measured with a volume flow probe on this compressor, 

this measurement channel must also be assigned to this compressor under “Flow and 

consumption”. If, as in this case, the actual amount of air supplied by the compressor was not 

measured, the delivered quantity will be calculated by the software with the theoretical value of 

0.95 m³/min, as specified in the configuration. 

The unit of pressure and air delivery can be changed too. If the unit is changed (from m³/h to 

m³/min) the values related to the unit are converted automatically.  

If the limit values for distinguishing load/idle and stop are to be corrected again, or graphically 

determined, press the button “Threshold limit" to access the graphic configuration area for the 

threshold limits. 

 

After performing the settings press the "Apply" button. 
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Illustration 64 : compressor added from database 

j) In order to see the details it is often required to first zoom in to the picture. Hereby, with the zoom 

function (hold down the shift key while simultaneously pressing the left mouse button and dragging 

a box across the area to be enlarged) zoom into the image as desired. With the right mouse 

button in the pop-up menu select “Apply current timespan” as soon as the zooming procedure was 

completed.  Then the detailed graph will be created with the current measurement values for this 

time period. 

 

The graph below shows the typical behavior curve of a “full/no load compressor”. 

Now, the threshold limit for the current consumption with which the software can distinguish 

between load and idle time can be moved graphically, and thus the software is able to calculate 

the appropriate times. Simply hold and move the red line with the mouse. Alternatively, the value 

can be set by using the arrow keys on the right side of the screen. 

The same applies for the threshold limit “Stop”. 

 

To jump to the left and right on the timeline the arrow keys on the  bottom right 

can be used. Alternatively, the time period there can also be chosen randomly. 
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Illustration 65 : set limit values 
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k) The second compressor, in this case a Compair LS 05 is also configured analog to the procedure 
of the first compressor. In this case, the current probe with which this compressor was measured, 
was connected to channel A3a of the DS500 (refer to “assigned measurements”). Also for this 
compressor the actual measurement of the delivered amount of air was not carried out with a 
volume flow probe, so that the assigned values for the volume flow and consumption are set to 
“none". 
 

 

Illustration 66 : second compressor added from database 

l) After both compressors are configured and saved, they will be available for selection in the 
"Compressor analysis". By clicking on the appropriate checkmark the individual compressors can 
be included in or omitted from the evaluation. 

 

Under “Overall flow" the radio buttons can be used to select if the total amount of air/flow of all 
compressors was measured with a volume flow sensor. Whereas in this case select the radio 
button “Volume flow sensor" and then select the appropriate measuring channel of the DS500 to 
which this sensor was connected, or whether the total amount of air/flow rate was not measured 
with a volume flow sensor and should be calculated by the software on the basis of the theoretical 
delivery quantity of the selected compressors. 

 

Under "Leakage", the measured leakage rate can be set so that the software is able to include this 
amount of leakage into the statistical analysis, including leakage costs. This however requires that 
an actual volumetric flow measurement is performed with a volume flow sensor. For this, the 
sensor must be installed downstream from the pressure tank in the main supply line to the 
compressed air consumers, so that during the operational stop times the compressed air that is 
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still delivered corresponds to the leakage quantity. (The installation of the sensor between 
compressor and the pressure tank is not recommended for this measurement because the flow 
sensor will then not be able to measure the amount of leakage, but rather only the amount that is 
supplied by the compressors). 

 

Under “Timespan” a selection can be performed for what time period the statistic is to be created. 
For the analysis of the compressor station it is advisable to always set the time frame to exactly 7 
days (or alternatively 14 days), because the software extrapolates the statistics based on these 7 
days for an entire working year (8700 hours). 

 

In addition to the statistics, other reports can be created. These can be selected or deselected 
with the appropriate checkmark.  

 

 

Illustration 67 : start compressor analysis 
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8 HowTo: Import CSV-Datei in Excel 2010 

1. Data -> from text 

2. Select CSV file 

3. Settings for text conversion: 
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4. Define the data format for all columns as a standard: 

 
 

5. Set further options via button „“Further …” as follows: 

 
 

6. Mark column A 

7. Select context menu “Formate cell“   

 

8. Select category “user-defined“ : 

 

Fix type of formatting to “TT.MM.JJJJ hh:mm:ss“ in order to ensure that also the seconds are 
indicated. 
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9 Licensing 

 After the installation you will automatically have a test version which is valid for 10 days. At the 
start of CS Soft Basic the remaining evaluation time will be displayed in the following dialog. 

 

Illustration 68: Info test version 

  
 

 With "?" you can select a different language. 

 If you downloaded the software from our homepage you can purchase a serial number in our 
online shop with the button "Purchase a serial number". 

 If you have a serial number, you can activate the software. 

 There are four ways to activate the software: 

 

Illustration 69: Activation options 
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 Please use in the "Online Activation" option if you're computer has an Internet connection. If 
your computer does not have Internet access, you can use "E-mail Activation" to activate any 
computer via e-mail. 
With the e-mail the activation code will be sent to you within 15 minutes.  

 Please use the registration by fax or telephone only if you do not have Internet access. 

 In the next step (independent from your activation option) please enter your activation data. 

 

Illustration 70: Activation data 

 With the "Online Activation" the registration is automatically completed, otherwise you must 
enter the activation key that has been sent to you at a later point in time through "Info-
>Licence button "Activation Key". 

If the software was activated online, there is the possibility of using the button "Transfer License" to 
transfer the software from computer A to computer B. 
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10 Support and Service 

If you have questions about our products or require technical support for the installation or use of our 
software, please contact us by e-mail: 

info@cs-instruments.com  

or by phone call: 

+49 461 7002025 

Phone support and Teamviewer access 
(15 minutes = 30 Euro, minimum 45min) 

We will answer all inquiries within 24-48 hours. 

 


